Status Update #5

On September 26, 2011, in CCIE, by Darren

I really need to try and find some for some content. The problem is I’m so extremely busy all the time at the moment.

This past weekend I did every single RIP lab in Vol.1 – That means I’ve completed ALL Vol1 labs for OSPF, EIGRP and RIP.

IGP’s has always been my strongest point anyway so it’s not that big a deal.

I need to do all BGP/MPLS and Multicast labs now.

Multicast has always been my biggest weakness so it’s something to concentrate on. Frame Relay usd to be a weakness, but I’ve done so much of it recently that’s it’s really not that difficult at all.

I’m very happy with my layer2 knowledge. I’ll go over all the layer2 labs again sometime though.

Finally it’s the services. Things like security and NAT. That stuff I’m not going to spend TOO much study time on. I mainly need to know what I can and cannot do, and where to find that info on the DocCD.

I still need to fit this all around a full time job. Wednesday night I’m taking my wife to a 2 hour comedy show, and then I’m heading straight into work after to do a core Juniper upgrade. Fun and games I tell you!

 

Status Update #4

On September 13, 2011, in Uncategorized, by Darren

Lot’s of things have been going on. There was a big announcement at work, but I’ll cover that in a later post.

Studying wise, I’ve done a LOT of Multicasting and OSPF studying. I’ve gone really deep into OSPF, using and configuring certain properties of the protocol that I just don’t see myself using in real life. You do need to know it for the exam though. Also at the end of the day it gives me a deeper understanding of the protocol itself, and I suppose it also gives me another tool on my ever expanding belt. I do need to come up with some posts explaining these properties.

I also upgraded my NAS. I had a Synology DS210j, upgraded now to a DS411. This gives me far more space and I can run raid5. I’ve got Sabnzdb, Sickbeard, Couch Potato, Headphones and a few other choice apps running on it :)

 

Disjointed OSPF areas without a virtual link

On September 6, 2011, in CCIE, by Darren

You should know by now that in order for multi-area OSPF to work, you need to have all areas connected to Area0.

If it’s not possible to have an area directly connected to Area0, you can create a virtual link to Area0. The virtual link itself is considered part of Area0.

However what happens if you’ve been asked to join Area2 to Area0 in the following topology, without using a virtual link?

tunnelospfarea0 Disjointed OSPF areas without a virtual link

R3 only has a direct link to R4. There are no more direct links between R3 and anywhere else.

At first it seems it can’t be done, but there is a way.

This is the relevant config for the current lab:
R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 10.1.12.1 255.255.255.0
 ip ospf 1 area 0
 

R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.12.2 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.24.2 255.255.255.0
 full-duplex
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 1
 network 10.1.12.2 0.0.0.0 area 0
 network 10.1.24.2 0.0.0.0 area 1

R2:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.34.3 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 2
 network 10.1.34.3 0.0.0.0 area 2

R4:

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip ospf 1 area 1
!
interface FastEthernet0/0
 ip address 10.1.34.4 255.255.255.0
 ip ospf 1 area 2
!
interface Ethernet1/0
 ip address 10.1.24.4 255.255.255.0
 ip ospf 1 area 1
 full-duplex

When we look at the routing tables, we’ll notice that R3 can’t see anything in Area 0 or Area 1. R4 can see everything as it is connected to R2, an ABR. It also has an interface in Area 2.

R3#sh ip route ospf




R4#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/12] via 10.1.24.2, 00:24:32, Ethernet1/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/11] via 10.1.24.2, 00:24:59, Ethernet1/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 10.1.34.3, 00:24:32, FastEthernet0/0
     10.0.0.0/24 is subnetted, 3 subnets
O IA    10.1.12.0 [110/11] via 10.1.24.2, 00:24:32, Ethernet1/0



R1#sh ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/2] via 10.1.12.2, 00:20:38, FastEthernet0/0
     4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/12] via 10.1.12.2, 00:20:27, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
O IA    10.1.24.0 [110/11] via 10.1.12.2, 00:20:38, FastEthernet0/0

R4 is in 2 areas, but it is not an ABR. An ABR is a router that is in more than 1 area, with 1 of those areas being the backbone area. Because R4 is not an ABR, there is no routing information being passed between Area 1 and Area 2. We could fix this with a virtual link, but I stated above that no virtual link is allowed.

So, we need to turn R4 into an ABR, but we can’t use a virtual link. An ABR means that at least one interface is in Area 0. That interface doesn’t HAVE to be a physical interface…

So how about creating a GRE tunnel? Let’s create a tunnel from R4 to R2 and stick that tunnel interface into Area 0.

R2:

interface Tunnel0
 ip address 10.24.24.2 255.255.255.0
 tunnel source Loopback0
 tunnel destination 4.4.4.4

router ospf 1
 network 10.24.24.2 0.0.0.0 area 0

R4:

interface Tunnel0
 ip address 10.24.24.4 255.255.255.0
 ip ospf 1 area 0
 tunnel source Loopback0
 tunnel destination 2.2.2.2
R4#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.12.2         0   FULL/  -        00:00:38    10.24.24.2      Tunnel0
10.1.12.2         1   FULL/BDR        00:00:39    10.1.24.2       Ethernet1/0
10.1.34.3         1   FULL/BDR        00:00:39    10.1.34.3       FastEthernet0/0

You can see the adjacency over the tunnel on R4. Hoes does R3′s routing table now look?

R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/11114] via 10.1.34.4, 00:02:46, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/12] via 10.1.34.4, 00:02:46, FastEthernet0/0
     4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/2] via 10.1.34.4, 00:02:46, FastEthernet0/0
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.1.12.0 [110/11113] via 10.1.34.4, 00:02:46, FastEthernet0/0
O IA    10.24.24.0 [110/11112] via 10.1.34.4, 00:02:46, FastEthernet0/0
O IA    10.1.24.0 [110/11] via 10.1.34.4, 00:02:46, FastEthernet0/0

It all works now, as R4 has been converted into a proper ABR. R4 has an interface in Area 0.

Of course if this tunnel goes down, it all breaks again!

 

© 2009-2014 Darren O'Connor All Rights Reserved