Upgrading JUNOS

Now that I got my olive up and running, it’s time to learn some stuff.

So how do you upgrade the JUNOS version on your device? With Cisco IOS it’s pretty easy. Copy the old IOS to your tftp server and then copy a new IOS image on and restart your box.

JUNOS doesn’t use tftp though, only regular ftp. You can either copy the images from with JUNOS itself, or just run an FTP server on the JUNOS box itself and ftp from your PC. I prefer the latter.

To run an FTP server on your router, make sure you’ve configured an interface with an IP and is reachable. Then add the following:

> configure
# set system services ftp
# commit

Make sure you actually have a user configured that can upload files. If it’s a temp user just do the following:

# set system login user ftpuser class super-user authentication plain-text-password

On your PC, open a command window and change to the directory containing your images. Then ftp into your JUNOS box:

C:\>ftp 10.4.10.10
Connected to 10.4.10.10.
220  FTP server (Version 6.00LS) ready.
User (10.4.10.10:(none)): ftpuser
331 Password required for ftpuser.
Password:
230 User ftpuser logged in.
ftp> bin
200 Type set to I.
ftp> cd /var/tmp
250 CWD command successful.
ftp> put jinstall-8.1R3.3-domestic-signed.tgz
200 PORT command successful.
150 Opening BINARY mode data connection for 'jinstall-8.1R3.3-domestic-signed.tgz'.
226 Transfer complete.
ftp: 93793459 bytes sent in 25.81Seconds 3634.42Kbytes/sec.
ftp> bye

Now get back to the juniper.

> request system software add /var/tmp/jinstall-8.1R3.3-domestic-signed.tgz

This will take a while to finish. Once complete, type the following:

> request system reboot

JUNOS should reboot twice in total, it’ll do this automatically. Once it comes back you’ll be in your new version:

root@% cli
root> show version
Model: olive
JUNOS Base OS boot [8.1R3.3]
JUNOS Base OS Software Suite [8.1R3.3]
JUNOS Kernel Software Suite [8.1R3.3]
JUNOS Crypto Software Suite [8.1R3.3]
JUNOS Packet Forwarding Engine Support (M/T Common) [8.1R3.3]
JUNOS Packet Forwarding Engine Support (M20/M40) [8.1R3.3]
JUNOS Online Documentation [8.1R3.3]
JUNOS Routing Software Suite [8.1R3.3]

Once done, remember to remove your ftpuser and the actual ftp server itself.

Why can’t my home network work correctly

I have xbmc installed on a Revo Acer 3600 in my bedroom. My media is sitting on a Synology NAS in the lounge in the next room. My database and media both sit on the NAS (i.e. remote mysql database)

When playing media wirelessly, at first it works wonders, but it always ends up freezing and xbmc just seems to completely freeze.

I’ve checked the debug log, and this is what I’m seeing:

20:30:25 T:3078395776 M:619479040  NOTICE: GL: Selecting Single Pass YUV 2 RGB shader
20:30:25 T:3078395776 M:619606016  NOTICE: GL: NPOT texture support detected
20:30:25 T:3078395776 M:619606016  NOTICE: GL: Using GL_ARB_pixel_buffer_object
20:31:12 T:2892065648 M:619679744 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
20:31:12 T:2881575792 M:619679744 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
20:31:33 T:2881575792 M:619720704   ERROR: Pause - pcm_pause, alsa error: -77 - File descriptor in bad state
20:31:33 T:2881575792 M:619720704 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush and prefix with 0 frames
20:38:18 T:2892065648 M:619831296 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
20:38:18 T:2881575792 M:619831296 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
20:38:27 T:2881575792 M:619831296 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush and prefix with 0 frames
20:50:10 T:2892065648 M:618541056 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
20:50:10 T:2881575792 M:618541056 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
20:52:06 T:2881575792 M:617766912 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush and prefix with 0 frames
20:56:36 T:2892065648 M:617775104 WARNING: Previous line repeats 3 times.
20:56:36 T:2892065648 M:617775104 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
20:56:36 T:2881575792 M:617775104 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
20:56:46 T:2881575792 M:617783296 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush and prefix with 0 frames
21:00:12 T:2892065648 M:617156608 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
21:00:12 T:2881575792 M:617156608 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
21:00:19 T:2881575792 M:617164800 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush and prefix with 0 frames
21:14:42 T:2892065648 M:616681472 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
21:14:42 T:2881575792 M:616681472 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
21:14:46 T:2881575792 M:616681472 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush and prefix with 0 frames

Basically I keep seeing this:

WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available

It’s pretty clear from the log that xbmc is complaining that it can’t get any new data packets. However this ONLY happens when playing media. If I copy stuff wirelessly, it can copy for hours without fault.

I know you might say that media requires a certain amount of bits per second. Correct, but I get the same freezing whether I’m testing a 1080p file or a standard ’320p’ file. Also it ALWAYS seems to happen roughly 6 – 8 minutes after I start playback, no matter if it’s HD or regular.

The wireless card on the Revo is a 54Mbps capable card and my router is a WRT-54GL with dd-wrt installed. I get anything between 24Mbps to 54Mbps. Of course this is wireless though – half-duplex and the speed is always going to change. There is no problem with the actual wireless connection between my NAS (Synology ds210j) and my Revo. I’ve got iperf installed on the NAS and Revo and this is my results.

This is my actual wireless connection in Linux:

mellowd@XBMCLive:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"Cisco"
Mode:Managed  Frequency:2.442 GHz  Access Point: 68:7F:74:XX:XX:XX
Bit Rate=54 Mb/s   Tx-Power=20 dBm
Retry  long limit:7   RTS thr:off   Fragment thr:off
Power Management:off
Link Quality=42/70  Signal level=-68 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0

TCP test:
NAS:

Simba> iperf -s -p 555  -i 10
------------------------------------------------------------
Server listening on TCP port 555
TCP window size: 85.3 KByte (default)
------------------------------------------------------------

Revo:

mellowd@XBMCLive:~$ iperf -c 10.20.30.4 -p 555  -i 10 -t 600
------------------------------------------------------------
Client connecting to 10.20.30.4, TCP port 555
TCP window size: 16.0 KByte (default)
------------------------------------------------------------
[  3] local 10.20.30.110 port 45553 connected with 10.20.30.4 port 555
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  19.2 MBytes  16.1 Mbits/sec
[  3] 10.0-20.0 sec  19.4 MBytes  16.3 Mbits/sec
[  3] 20.0-30.0 sec  18.6 MBytes  15.6 Mbits/sec
[  3] 30.0-40.0 sec  18.4 MBytes  15.4 Mbits/sec
[  3] 40.0-50.0 sec  18.5 MBytes  15.5 Mbits/sec
[  3] 50.0-60.0 sec  18.4 MBytes  15.4 Mbits/sec
[  3] 60.0-70.0 sec  15.7 MBytes  13.1 Mbits/sec
[  3] 70.0-80.0 sec  16.9 MBytes  14.2 Mbits/sec
.
.
.
.
.
.
[  3] 270.0-280.0 sec  18.7 MBytes  15.7 Mbits/sec
^C[  3]  0.0-285.7 sec    503 MBytes  14.8 Mbits/sec

Right, so I’m getting roughly 14Mbits/sec minimum average.

Let’s now do a UDP test at that speed to see if there is any jitter or packet loss
UDP test:
NAS:

Simba> iperf -s -p 555 -u -i 10
------------------------------------------------------------
Server listening on UDP port 555
Receiving 1470 byte datagrams
UDP buffer size:   106 KByte (default)
------------------------------------------------------------

Revo:

mellowd@XBMCLive:~$ iperf -c 10.20.30.4 -p 555 -u -i 10 -t 420 -b 14000000
------------------------------------------------------------
Client connecting to 10.20.30.4, UDP port 555
Sending 1470 byte datagrams
UDP buffer size:   110 KByte (default)
------------------------------------------------------------
[  3] local 10.20.30.110 port 42693 connected with 10.20.30.4 port 555
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  15.5 MBytes  13.0 Mbits/sec
[  3] 10.0-20.0 sec  16.5 MBytes  13.9 Mbits/sec
[  3] 20.0-30.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 30.0-40.0 sec  16.5 MBytes  13.8 Mbits/sec
[  3] 40.0-50.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 50.0-60.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 60.0-70.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 70.0-80.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 80.0-90.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 90.0-100.0 sec  16.4 MBytes  13.8 Mbits/sec
[  3] 100.0-110.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 110.0-120.0 sec  14.6 MBytes  12.2 Mbits/sec
[  3] 120.0-130.0 sec  16.4 MBytes  13.8 Mbits/sec
[  3] 130.0-140.0 sec  16.5 MBytes  13.9 Mbits/sec
[  3] 140.0-150.0 sec  16.4 MBytes  13.8 Mbits/sec
[  3] 150.0-160.0 sec  16.2 MBytes  13.6 Mbits/sec
[  3] 160.0-170.0 sec  16.5 MBytes  13.8 Mbits/sec
[  3] 170.0-180.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 180.0-190.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 190.0-200.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 200.0-210.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 210.0-220.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 220.0-230.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 230.0-240.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 240.0-250.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 250.0-260.0 sec  16.2 MBytes  13.6 Mbits/sec
[  3] 260.0-270.0 sec  16.7 MBytes  14.0 Mbits/sec
[  3] 270.0-280.0 sec  16.0 MBytes  13.4 Mbits/sec
[  3] 280.0-290.0 sec  14.5 MBytes  12.2 Mbits/sec
[  3] 290.0-300.0 sec  16.6 MBytes  13.9 Mbits/sec
[  3] 300.0-310.0 sec  14.8 MBytes  12.4 Mbits/sec
[  3] 310.0-320.0 sec  14.8 MBytes  12.4 Mbits/sec
[  3] 320.0-330.0 sec  15.8 MBytes  13.2 Mbits/sec
[  3] 330.0-340.0 sec  14.5 MBytes  12.2 Mbits/sec
[  3] 340.0-350.0 sec  15.7 MBytes  13.2 Mbits/sec
[  3] 350.0-360.0 sec  14.9 MBytes  12.5 Mbits/sec
[  3] 360.0-370.0 sec  15.6 MBytes  13.1 Mbits/sec
[  3] 370.0-380.0 sec  16.4 MBytes  13.7 Mbits/sec
[  3] 380.0-390.0 sec  13.7 MBytes  11.5 Mbits/sec
[  3] 390.0-400.0 sec  13.4 MBytes  11.2 Mbits/sec
[  3] 400.0-410.0 sec  16.0 MBytes  13.4 Mbits/sec
[  3] 410.0-420.0 sec  14.8 MBytes  12.4 Mbits/sec
[  3]  0.0-420.0 sec    672 MBytes  13.4 Mbits/sec
[  3] Sent 479149 datagrams
[  3] Server Report:
[  3]  0.0-419.8 sec    672 MBytes  13.4 Mbits/sec  2.677 ms    0/479148 (0%)
[  3]  0.0-419.8 sec  1 datagrams received out-of-order

Not a bad result. 479148 datagrams sent with only 1 out of order. What does the server show?
NAS:

Simba> iperf -s -p 555 -u -i 10
------------------------------------------------------------
Server listening on UDP port 555
Receiving 1470 byte datagrams
UDP buffer size:   106 KByte (default)
------------------------------------------------------------
[  3] local 10.20.30.4 port 555 connected with 10.20.30.110 port 42693
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3]  0.0-10.0 sec  15.5 MBytes  13.0 Mbits/sec  0.675 ms    0/11027 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 10.0-20.0 sec  16.6 MBytes  13.9 Mbits/sec  0.369 ms    0/11836 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 20.0-30.0 sec  16.7 MBytes  14.0 Mbits/sec  0.618 ms    0/11909 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 30.0-40.0 sec  16.5 MBytes  13.8 Mbits/sec  0.432 ms    0/11770 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 40.0-50.0 sec  16.7 MBytes  14.0 Mbits/sec  0.364 ms    0/11912 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 50.0-60.0 sec  16.5 MBytes  13.9 Mbits/sec  0.571 ms    0/11800 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 60.0-70.0 sec  16.7 MBytes  14.0 Mbits/sec  0.424 ms    0/11900 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 70.0-80.0 sec  16.6 MBytes  13.9 Mbits/sec  0.290 ms    0/11853 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 80.0-90.0 sec  16.7 MBytes  14.0 Mbits/sec  1.921 ms    0/11878 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 90.0-100.0 sec  16.5 MBytes  13.8 Mbits/sec  1.038 ms    0/11739 (0%)
.
.
.
.
.
.
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3] 400.0-410.0 sec  16.1 MBytes  13.5 Mbits/sec  0.443 ms    0/11477 (0%)
[ ID] Interval       Transfer     Bandwidth       Jitter   Lost/Total Datagrams
[  3]  0.0-419.8 sec    672 MBytes  13.4 Mbits/sec  2.677 ms    0/479148 (0%)
[  3]  0.0-419.8 sec  1 datagrams received out-of-order

At 14Mb/s – there is 0% data loss. Jitter is also very good. In 7 minues it transfered 672MB

Why then can I not watch a 350Mb file which lasts 40 minutes over this SAME link?

Seems like bad programming on the xbmc side as far as I’m concerned. I have posted on xbmc’s forum with no developer taking note.

/31′s effect on routing protocols – Round 2

I got a question about whether /31′s would affect routing protocols on other devices, not just the Cisco I tested previously.

Let’s recap the topology I used before.31lab /31s effect on routing protocols   Round 2
R2 is going to be a Cisco 3560 and R1 for now is a Juniper SSG5.

Quick configs.
Juniper SSG:

set interface ethernet0/0 ip 10.1.1.2/31
set interface ethernet0/0 route
set interface loopback.1 ip 172.16.1.1/24
set interface loopback.1 route
!
set access-list 10
set access-list 10 permit ip 172.16.1.0/24 10
set route-map name "p" permit 10
set match interface ethernet0/0 loopback.1
set match ip 10
!
set interface ethernet0/0 protocol ospf area 0.0.0.0
set interface ethernet0/0 protocol ospf enable
set interface loopback.1 protocol ospf area 0.0.0.0
set interface loopback.1 protocol ospf enable

Cisco:

interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 ip address 10.1.1.3 255.255.255.254
!
router ospf 1
 redistribute connected subnets
 network 10.1.1.3 0.0.0.0 area 0

Are they neighbours?
Juniper SSG:

ssg5-serial-> get interface eth0/0 protocol ospf
VR: trust-vr RouterId: 192.168.2.1
----------------------------------
Interface: ethernet0/0
IpAddr: 10.1.1.2/31, OSPF: enabled, Router: enabled
Type: Broadcast  Area: 0.0.0.0  Priority: 1  Cost: 1  Passive: No
Transit delay: 1s  Retransmit interval: 5s  Hello interval: 10s
Router Dead interval: 40s  Authentication-Type: None
Ignore-MTU: no Reduce-flooding: no
State: Backup Designated Router  DR: 10.1.1.3  BDR: 10.1.1.2(self)
Neighbors:
        RtrId: 10.1.1.3 IpAddr: 10.1.1.3 Pri: 1 State: Full

Cisco:

Switch#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.2.1       1   FULL/BDR        00:00:34    10.1.1.2        FastEthernet0/1

Finally, can they see the routes and ping the loopbacks?

Juniper:

ssg5-serial-> get route

IPv4 Dest-Routes for  (0 entries)
--------------------------------------------------------------------------------------
H: Host C: Connected S: Static A: Auto-Exported
I: Imported R: RIP P: Permanent D: Auto-Discovered
N: NHRP
iB: IBGP eB: EBGP O: OSPF E1: OSPF external type 1
E2: OSPF external type 2 trailing B: backup route

IPv4 Dest-Routes for
 (6 entries)
--------------------------------------------------------------------------------------
         ID          IP-Prefix      Interface         Gateway   P Pref    Mtr     Vsys
--------------------------------------------------------------------------------------
*         9        10.1.1.2/32         eth0/0         0.0.0.0   H    0      0     Root
*         8        10.1.1.2/31         eth0/0         0.0.0.0   C    0      0     Root
*         3      172.16.1.0/24     loopback.1         0.0.0.0   C    0      0     Root
*         5     192.168.2.1/32         eth0/5         0.0.0.0   H    0      0     Root
*         4     192.168.2.0/24         eth0/5         0.0.0.0   C    0      0     Root
*        11     192.168.1.0/24         eth0/0        10.1.1.3  E2  200     20     Root

ssg5-serial-> ping 192.168.1.1
Type escape sequence to abort

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 1 seconds
!!!!!
Success Rate is 100 percent (5/5), round-trip time min/avg/max=2/3/4 ms

Cisco:

Switch#sh ip route

     172.16.0.0/24 is subnetted, 1 subnets
O       172.16.1.0 [110/2] via 10.1.1.2, 00:12:37, FastEthernet0/1
     10.0.0.0/31 is subnetted, 1 subnets
C       10.1.1.2 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, Loopback0
Switch#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

To be honest, I’m not even going to bother with RIP. I never use it, so what for?

We use Foundry/Brocade routers as well, so how do they hold up?

Foundry config:

SSH@foundry(config-if-e1000-1/6)#ip address 10.1.1.2/31
IP/Port: Errno(9) Cannot assign broadcast address

SSH@foundry(config-if-e1000-1/6)#ip address 10.1.1.3/31
IP/Port: Errno(9) Cannot assign broadcast address

SSH@foundry(config-if-e1000-1/6)#ip address 10.1.1.4/31
IP/Port: Errno(9) Cannot assign broadcast address

The Foundry won’t even allow me to assign the IP address. As a note I’m using fairly recent code:

SL M1: NI-XMR-MR Management Module Active (Serial #: XXXXXXXXX, Part #: XXXXX-XXXX):
Boot     : Version 5.0.0T165 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.
Compiled on Apr 19 2010 at 17:27:10 labeled as xmprm05000

What about JUNOS itself?
Juniper config:

root> show configuration
version 7.1R2.2;
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 10.1.1.2/31;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 172.16.1.1/32;
            }
        }
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface 10.1.1.2;
            interface 172.16.1.1;
        }
    }
}

Cisco same as the previous examples.

Neighbours?
JUNOS:

root> show ospf neighbor
  Address         Interface             State      ID              Pri  Dead
10.1.1.3         fxp0.0                 Full      192.168.1.1        1   39

Cisco:

Router#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1      128   FULL/DR         00:00:38    10.1.1.2        FastEthernet0/1

Routes?
JUNOS:

root> show route

inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.1.1.2/31        *[Direct/0] 00:08:12
                    > via fxp0.0
10.1.1.2/32        *[Local/0] 00:08:12
                      Local via fxp0.0
172.16.1.1/32      *[Direct/0] 00:06:03
                    > via lo0.0
192.168.1.1/32     *[OSPF/10] 00:03:26, metric 2
                    > to 10.1.1.3 via fxp0.0

root> ping 192.168.1.1 count 5
PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=1.250 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=1.273 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=1.222 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=1.267 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=255 time=1.215 ms

--- 192.168.1.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.215/1.245/1.273/0.023 ms

Cisco:

Router#sh ip route

Gateway of last resort is not set

     172.16.0.0/32 is subnetted, 1 subnets
O       172.16.1.1 [110/1] via 10.1.1.2, 00:04:18, FastEthernet0/1
     10.0.0.0/31 is subnetted, 1 subnets
C       10.1.1.2 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, Loopback0

Router#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Most seem to work. I’m a bit upset about the Brocade/Foundry result though!

Juniper olive on old Nokia IP330

I’ve been wanting to do more Juniper studies. Unfortunately at work we only have 2 Junipers on the BGP edge so we don’t exactly get to play with them.

I’ve known about olives on the PC for a while, but I wanted something better. I could not afford to buy a J2300 so I went he next best route – The 1U Olive

I’ve just got it working too!

root> show version
Model: olive
JUNOS Base OS boot [7.1R2.2]
JUNOS Base OS Software Suite [7.1R2.2]
JUNOS Kernel Software Suite [7.1R2.2]
JUNOS Packet Forwarding Engine Support (M20/M40) [7.1R2.2]
JUNOS Routing Software Suite [7.1R2.2]
JUNOS Online Documentation [7.1R2.2]
JUNOS Crypto Software Suite [7.1R2.2]

root> show interfaces terse
Interface Admin Link Proto Local Remote
dsc up up
fxp0 up down
fxp1 up down
fxp2 up down
gre up up
ipip up up
lo0 up up
lo0.16385 up up inet
inet6 fe80::200:ff:fe00:1
lsi up up
mtun up up
pimd up up
pime up up
tap up up

I’ve got a couple of other IP330′s so I just need to replicate this. I’ll stick this in the lab. This essentially gives 4 me Juniper routers!

The next step is to upgrade the JUNOS version on this one and do a few more. Then put them together and see what happens.